개념 324
-
2단계 인증
2SV · two-step verification · 2-step verification · 2단계 확인
-
3D 재현
3D reconstruction · 3차원 복원 · 3D 복원 · 3차원 재구성
-
ABI
Application Binary Interface · 응용 프로그램 이진 인터페이스 · 바이너리 인터페이스
-
ACID
Atomicity Consistency Isolation Durability · ACID 성질 · ACID 속성 · 애시드
-
ANSI
American National Standards Institute · 미국 국가표준협회 · 안시
-
API
Application Programming Interface · application programming interface · 응용 프로그램 인터페이스
-
API 키
API key · api key · API 키 값
-
CDN
Content Delivery Network · Content Distribution Network · 콘텐츠 전송 네트워크
-
CLOCK_MONOTONIC
clock_monotonic · MONOTONIC 시계
-
CLOCK_PROCESS_CPUTIME_ID
clock_process_cputime_id · 프로세스 CPU 시간 시계 · 프로세스 CPU 시계
-
CLOCK_REALTIME
clock_realtime · REALTIME 시계
-
CLOCK_TAI
clock_tai · TAI 시계
-
CLOCK_THREAD_CPUTIME_ID
clock_thread_cputime_id · 스레드 CPU 시간 시계 · 스레드 CPU 시계
-
CLS
Cumulative Layout Shift · 누적 레이아웃 이동
-
CPU
Central Processing Unit · 중앙처리장치 · 프로세서
-
CPU 캐시
CPU cache · 캐시 메모리 · cache memory · 프로세서 캐시
-
DMA
Direct Memory Access · 직접 메모리 접근 · 직접 메모리 액세스
-
DNS 캐시
DNS cache · DNS 캐싱
-
DORA
DevOps Research and Assessment · DORA 지표 · DORA metrics
-
ELT
Extract Load Transform · 추출·적재·변환 · 추출 적재 변환
-
ETL
Extract Transform Load · 추출·변환·적재 · 추출 변환 적재
-
GPIO
General-Purpose Input/Output · 범용 입출력 · GPIO 핀 · 범용 입출력 핀
-
GPU
Graphics Processing Unit · 그래픽 처리 장치 · 그래픽카드
-
HDR
High Dynamic Range · 하이 다이내믹 레인지 · 하이 다이나믹 레인지 · 높은 다이내믹 레인지 · 고명암비
-
HTTP 요청
HTTP request · HTTP 요청 메시지 · 요청 메시지
-
HTTP 응답
HTTP response · HTTP 응답 메시지 · 응답 메시지
-
HTTP 캐시
HTTP cache · 웹 캐시 · web cache
-
IAB
Internet Architecture Board · 인터넷 아키텍처 위원회
-
IANA
Internet Assigned Numbers Authority
-
IETF
Internet Engineering Task Force
-
INP
Interaction to Next Paint · 다음 페인트까지의 상호작용
-
IP 주소
IP address · IP 어드레스 · 아이피 주소
-
ISO
International Organization for Standardization · 국제표준화기구
-
JIT 컴파일
JIT · JIT 컴파일러 · just-in-time compilation · 적시 컴파일 · 동적 컴파일
-
LCP
Largest Contentful Paint · 최대 콘텐츠풀 페인트 · 최대 콘텐츠 페인트
-
LOD
Level of Detail · 레벨 오브 디테일 · 세부 수준
-
MAC 주소
MAC address · 맥 주소 · 하드웨어 주소 · 이더넷 주소
-
MMU
Memory Management Unit · 메모리 관리 장치
-
MTRR
Memory Type Range Register · Memory Type Range Registers · 메모리 타입 범위 레지스터
-
MTU
Maximum Transmission Unit · 최대 전송 단위
-
Microsoft
마이크로소프트 · Microsoft Corporation
-
NAT
Network Address Translation · 네트워크 주소 변환 · 주소 변환 · NAPT · PAT · IP 마스커레이드
-
NP 클래스
NP · NP class · Nondeterministic Polynomial time · 비결정적 다항 시간 · 클래스 NP
-
NP-난해
NP-hard · NP-하드 · NP 난해 · NP-hardness
-
NP-완전
NP-complete · NP-completeness · NP 완전 · NP-컴플리트 · NPC
-
OASIS
Organization for the Advancement of Structured Information Standards · OASIS Open · 오아시스 · 구조화 정보 표준 발전 기구
-
OOM 킬러
OOM killer · Out Of Memory killer · oom-killer · OOM 킬 · 메모리 부족 킬러
-
OWASP
Open Worldwide Application Security Project · Open Web Application Security Project · OWASP 재단
-
P 대 NP
P 대 NP 문제 · P vs NP · P versus NP · P vs NP problem · P=NP 문제
-
P 클래스
P · PTIME · class P · 다항 시간 클래스 · P 복잡도 클래스
-
PCI Security Standards Council
PCI SSC · Payment Card Industry Security Standards Council · 결제 카드 산업 보안 표준 위원회 · PCI 보안 표준 위원회
-
SDK
Software Development Kit · software development kit · 소프트웨어 개발 키트
-
SO_REUSEADDR
so_reuseaddr · SO_REUSEADDR 옵션 · reuseaddr · 주소 재사용 옵션
-
SRE
Site Reliability Engineering · 사이트 신뢰성 엔지니어링
-
TIME_WAIT
TIME-WAIT · time_wait · TIME_WAIT 상태 · 타임 웨이트
-
TLB
Translation Lookaside Buffer · 변환 색인 버퍼 · 주소 변환 캐시
-
TREC
Text REtrieval Conference · 텍스트 검색 컨퍼런스 · TREC 대회
-
UT1
Universal Time 1 · 세계시 1
-
UTC 오프셋
UTC offset · 시간대 오프셋 · 타임존 오프셋
-
VPN
Virtual Private Network · 가상 사설망 · 브이피엔
-
W3C
World Wide Web Consortium · 월드 와이드 웹 컨소시엄
-
WHATWG
Web Hypertext Application Technology Working Group · 왓위그
-
Web Vitals
웹 바이탈 · 웹 바이탈스
-
cgroup
control group · 컨트롤 그룹 · 제어 그룹 · cgroups · cgroup v2
-
dirty 페이지
dirty page · 더티 페이지 · dirty buffer · 더티 버퍼
-
happens-before
happened-before · happens before
-
p값
p-value · p value · p-값 · 유의 확률
-
sRGB 프레임버퍼
sRGB framebuffer · sRGB 프레임 버퍼 · sRGB 렌더 타깃
-
time_t
time_t 타입
-
vblank
vertical blanking · vertical blanking interval · VBI · V-blank · 수직 귀선 구간 · 수직 공백 구간 · 수직 블랭킹
-
가비지 컬렉션
GC · garbage collection · 가비지 수집
-
가상 DOM
virtual DOM · VDOM · 버추얼 DOM
-
가상 머신
virtual machine · VM · 버추얼 머신
-
가상 메모리
virtual memory · 가상 기억 장치
-
가상 사용자
virtual user · VU · virtual users
-
가상화
virtualization · 버추얼라이제이션 · 서버 가상화
-
가용성
availability · 가용률
-
간접 라우팅
indirect routing · indirect delivery · 간접 전달
-
감마 보정
gamma correction · gamma encoding · 감마 인코딩 · 감마 부호화
-
감사 로그
audit log · 감사 추적 · audit trail
-
강체 물리
rigid body physics · rigid body dynamics · rigid body simulation · 강체 동역학 · 강체 시뮬레이션
-
강한 일관성
strong consistency · strongly consistent · 강한 정합성 · 강일관성
-
강화학습
reinforcement learning · 강화 학습 · RL
-
개념 모델
conceptual model · conceptual data model · 개념 데이터 모델 · 개념적 데이터 모델 · 개념적 모델
-
개발자 도구
DevTools · developer tools · 브라우저 개발자 도구 · 데브툴즈
-
객체 검출
object detection · 물체 검출 · 객체 탐지 · 오브젝트 디텍션
-
객체 저장소
object storage · 오브젝트 스토리지 · 객체 스토리지
-
객체지향 데이터베이스
object-oriented database · OODB · OODBMS · object database · 객체 데이터베이스 · 객체지향 DBMS
-
검색 엔진
search engine · 검색엔진 · 전문 검색 엔진
-
검색 엔진 라이브러리
search engine library · 검색 라이브러리 · 전문 검색 라이브러리 · full-text search library
-
검증
validation · verification
-
검증과 확인
verification and validation · V&V · 검증 및 확인
-
게이트웨이
gateway · HTTP 게이트웨이
-
게임 상태 직렬화
game state serialization · 상태 직렬화 · 게임 상태 저장
-
격리
isolation · isolate
-
격리 수준
isolation level · transaction isolation level · 트랜잭션 격리 수준
-
결과 그룹핑
result grouping · field collapsing · 필드 접기 · 결과 접기 · 검색 결과 그룹핑 · 결과 묶기
-
결과적 일관성
eventual consistency · eventually consistent · 최종 일관성 · 궁극적 일관성 · 결과적 정합성
-
결정론적 시뮬레이션
deterministic simulation · 결정적 시뮬레이션 · 결정론 시뮬레이션
-
결정성
determinism · deterministic · 결정적
-
결측치
missing value · 결측값 · 누락값
-
결합 문자
combining character · combining mark · 결합 부호 · 결합 기호
-
결합도
coupling · 커플링 · 모듈 결합도
- 경보
-
계산가능성
computability · 계산 가능성 · 계산 가능 · 계산 불가능
-
계측
instrumentation · 인스트루멘테이션
-
계층
layer · 레이어
-
계층형 데이터베이스
hierarchical database · 계층형 데이터 모델 · 계층 데이터 모델 · 계층형 DBMS · hierarchical model
-
고가용성
High Availability · HA · 고가용성 구성
-
고루틴
goroutine · goroutines
-
고차원 벡터
high-dimensional vector · high-dimensional vectors · high dimensional vector
-
공간 복잡도
space complexity
-
공개키 기반구조
PKI · Public Key Infrastructure · 공개 키 기반 구조 · 공개키 기반 구조
-
공격 표면
attack surface · 공격면
-
공급망 공격
supply chain attack · 소프트웨어 공급망 공격 · software supply chain attack · 서플라이 체인 공격
-
공유 라이브러리
shared library · shared object · 공유 오브젝트 · 동적 라이브러리 · DLL · dylib
-
공유 캐시
shared cache · 공용 캐시
-
관계형 데이터베이스
relational database
-
관계형 모델
relational model · 관계형 데이터 모델 · 관계 데이터 모델
-
관측성
observability · 옵저버빌리티
-
관측성 백엔드
observability backend · 관측 백엔드 · 텔레메트리 백엔드
-
구체화 뷰
materialized view · 실체화 뷰 · 구체화된 뷰
-
구현 정의 동작
implementation-defined behavior · implementation-defined behaviour · 구현 정의 행동 · 구현 의존 동작
-
군집화
clustering · Clustering · 클러스터링 · 군집 분석 · cluster analysis · 클러스터 분석
-
권위 서버
authoritative server · server authority · server-authoritative · 서버 권위 · 서버 권위 방식 · 권위적 서버 · 권위 있는 서버
-
권한
permission · privilege · 퍼미션
-
권한 상승
privilege escalation · elevation of privilege
-
귀무가설
null hypothesis · H0 · 영가설 · 귀무 가설
-
그래픽 드라이버
graphics driver · GPU 드라이버 · 그래픽 카드 드라이버 · 디스플레이 드라이버
-
그래픽스 파이프라인
graphics pipeline · 렌더링 파이프라인 · rendering pipeline · 그래픽 파이프라인
-
기계어
machine code · machine language · 기계 코드 · 기계 언어
-
기능 테스트
functional test · functional testing · 기능 시험 · 기능성 테스트
-
기본 게이트웨이
default gateway · 디폴트 게이트웨이
-
기본 키
primary key · PK
-
기술 부채
technical debt · 기술 빚 · 테크 부채
-
깊이 경계 테스트
depth bounds test · 뎁스 바운즈 테스트 · 깊이 범위 테스트
-
깊이 버퍼
depth buffer · z-buffer · Z 버퍼 · 뎁스 버퍼
-
깊이 정밀도
depth precision · Z 정밀도 · 깊이 버퍼 정밀도
-
깊이 테스트
depth test · 뎁스 테스트 · Z 테스트 · z-test · depth buffer test · 깊이 버퍼 테스트
-
꼬리 지연
tail latency · 꼬리지연 · 테일 레이턴시
-
나이
응답 나이 · 캐시 나이 · response age
-
넓은 범위 테스트
large-scoped test · large-scope test · broad-scoped test · large-scoped · 넓은 범위의 테스트 · 광범위 테스트
-
네임스페이스
namespace · 이름 공간 · namespaces
-
네트워크 네임스페이스
network namespace · netns · net namespace · 넷 네임스페이스
-
네트워크 인터페이스
network interface
-
논리 모델
logical model · logical data model · 논리 데이터 모델 · 논리적 데이터 모델 · 논리적 모델
-
논리 시계
logical clock · 논리 클록 · 논리적 시계
-
논리 연산
logical operation · logic operation · logic op · 로직 연산
-
논리적 복제
logical replication · 로지컬 레플리케이션 · 논리 복제 · 행 기반 복제
-
논블로킹 입출력
non-blocking IO · nonblocking IO · 논블로킹 IO · 논블로킹 I-O · 넌블로킹 입출력
-
높은 분위수
high percentile · high quantile · tail percentile · 높은 백분위수 · 상위 분위수
-
다음 홉
next hop · 넥스트 홉 · next-hop
-
다중 등급 보안
MLS · Multilevel Security · Multi-Level Security · 다단계 보안 · 다중 수준 보안
-
다중 인증
MFA · multi-factor authentication · 다요소 인증 · 2FA · two-factor authentication · 이중 인증
-
다중 프로그래밍
multiprogramming · 멀티프로그래밍 · 다중 프로그램 처리
-
다중화
multiplexing · 멀티플렉싱
-
단위 테스트
unit test · unit testing · 유닛 테스트 · 단위 시험
-
단일 장애점
SPOF · Single Point of Failure
-
단일 진실 원천
Single Source of Truth · single source of truth · SSOT · 단일 진실 공급원
-
단조 시계
monotonic clock · 단조시계 · 모노토닉 클록
-
단편화
fragmentation
-
단편화와 재조립
fragmentation and reassembly · IP fragmentation · IP 단편화 · 패킷 단편화
-
대상
target · 타깃 · 타겟
-
대시보드
dashboard · 모니터링 대시보드
-
대체 문자
replacement character · REPLACEMENT CHARACTER · U+FFFD
-
대체 텍스트
alt text · alternative text · 대안 텍스트
-
데이터 계보
data lineage · 데이터 리니지
-
데이터 독립성
data independence · 데이터 독립
-
데이터 마트
data mart · 데이터마트
-
데이터 모델링
data modeling · 데이터모델링
-
데이터 서브언어
data sublanguage · Data Sublanguage · 데이터 하위 언어 · 데이터 부분 언어
-
데이터 시각화
data visualization · Data Visualization · 시각화 · 데이터 비주얼라이제이션
-
데이터 웨어하우스
data warehouse · DWH · 데이터웨어하우스 · 웨어하우스
-
데이터 카탈로그
data catalog · 데이터카탈로그
-
데이터 타입
data type · datatype · data types · 자료형 · 타입
-
데이터 통합
data integration · 데이터 연계
-
데이터 품질
Data Quality · data quality · DQ
-
데이터그램
datagram · 데이터그램 방식
-
데이터베이스
database · 디비
-
데이터베이스 관리 시스템
DBMS · Database Management System
-
데이터셋
dataset · data set · 데이터 세트 · 데이터 집합
-
데이터플로우 그래프
dataflow graph · data flow graph · 데이터 흐름 그래프 · 데이터플로 그래프
-
델타 타임
delta time · dt · deltaTime · Δt · 델타타임 · 프레임 간 시간
-
도메인 분리
domain separation
-
동시성
concurrency · 병행성
-
동일 출처 정책
same-origin policy · Same-Origin Policy · SOP · 동일 출처 원칙 · 같은 출처 정책
-
동적 링커
dynamic linker · dynamic loader · 동적 로더 · 런타임 링커
-
동적 링크
dynamic linking · dynamic link · 동적 연결 · 런타임 링크
-
동적 분석
dynamic analysis · 동적분석 · 동적 프로그램 분석
-
동적 상태
dynamic state · VkDynamicState · 동적 파이프라인 상태 · pipeline dynamic state
-
되돌리기
undo · revert · 언두 · 리버트
-
디맨드 페이징
demand paging · 요구 페이징 · 디맨드페이징
-
디바이스 드라이버
device driver · 장치 드라이버
-
디바이스 메모리
device memory · 장치 메모리 · GPU 메모리 · 그래픽 메모리
-
디스크
disk · 보조기억장치 · 디스크 드라이브 · 하드 디스크
-
디스크 입출력
disk IO · disk I-O · 디스크 IO · 디스크 I-O
-
디스크립터
descriptor · 서술자 · 기술자
-
디스크립터 세트
descriptor set · VkDescriptorSet · 디스크립터 집합
-
디스크립터 세트 레이아웃
descriptor set layout · VkDescriptorSetLayout · 세트 레이아웃
-
디스크립터 타입
descriptor type · VkDescriptorType · 디스크립터 종류
-
딥 링크
deep link · deep linking · 딥링크 · 딥 링킹
-
딥러닝
deep learning · 심층 학습
-
라우터
router · 라우팅 장비
-
라우팅
routing · 경로 선택
-
락
lock · 잠금
-
랭킹
ranking · 순위 매기기 · 검색 랭킹 · 결과 순위
-
런타임 권한
runtime permission · 위험 권한 · dangerous permission · 런타임 퍼미션
-
레이 생성 셰이더
ray generation shader · raygen shader · 광선 생성 셰이더 · 레이 제너레이션 셰이더 · 레이젠 셰이더
-
레이 트레이싱 파이프라인
ray tracing pipeline · raytracing pipeline · 광선 추적 파이프라인 · 레이트레이싱 파이프라인
-
레이블
label · 라벨
-
레이아웃
layout · 레이아웃 계산
-
레지스터
register · 프로세서 레지스터 · CPU 레지스터
-
레플리카 샤드
replica shard
-
렌더 타깃
render target · 렌더 타겟
-
렌더 트리
render tree · 렌더링 트리
-
렌더 파이프라인
render pipeline
-
렌더 패스
render pass · 렌더패스
-
렌더링
rendering · 렌더
-
렌더링 방정식
rendering equation · 렌더 방정식
-
렌더링 엔진
rendering engine · 브라우저 엔진 · browser engine · 레이아웃 엔진 · layout engine
-
로그
log
-
로더
loader · 적재기 · 프로그램 로더
-
로드 밸런서
로드밸런서 · load balancer · LB · 부하 분산기
-
로드 연산
load operation · load op · loadOp · load action · 로드 오퍼레이션
-
롤
역할 · 데이터베이스 롤 · DB 롤
-
롤백
rollback
-
롤아웃
rollout · 롤 아웃
-
리버스 프록시 캐시
reverse proxy cache · 게이트웨이 캐시 · gateway cache
-
리베이스
rebase · git rebase · 리베이싱
-
리비전
revision · 리비전 번호 · revision number
-
리비전 이력
revision history · 변경 이력 · 버전 이력
-
리페인트
repaint · repainting · 리페인팅
-
리프레시 토큰
refresh token
-
리플로
reflow · 리플로우
-
링커
linker · link editor · 링크 편집기 · 연결 편집기
-
링크 계층
link layer · L2 · 2계층 · 네트워크 인터페이스 계층
-
마이너 릴리스
minor release · 마이너 버전 · minor version · 마이너 업데이트 · 기능 릴리스
-
만료
expiration · expiry
-
머신 이미지
machine image · 가상 머신 이미지 · VM 이미지 · 서버 이미지
-
머신러닝
machine learning · 기계학습
-
머티리얼
material · 재질
-
멀티샘플 커버리지
multisample coverage · sample coverage · 샘플 커버리지 · MSAA 커버리지
-
멀티태스킹
multitasking · 다중 작업 · 다중 태스킹
-
멀티호밍
multihoming · multi-homing · 멀티홈 · 멀티홈드 호스트 · multihomed host
-
메모리
memory · 주기억장치 · 주 메모리 · main memory · RAM · 램
-
메모리 모델
memory model · 메모리 일관성 모델
-
메모리 안전
memory safety · 메모리 안전성
-
메시
Mesh · mesh
-
메시 셰이더
mesh shader · 메쉬 셰이더 · 메시 쉐이더
-
메시지
message
-
메시지 경계
message boundary · message boundaries · 메시지 경계 보존
-
메시지 인증 코드
MAC · Message Authentication Code · 인증 태그 · authentication tag
-
메시지 전달
message passing · 메시지 패싱
-
메이저 버전
major version · 메이저 릴리스 · major release · 주 버전 · 메이저 번호
-
메타데이터
metadata · 메타 데이터
-
메트릭
metric · metrics
-
멱등성
idempotence · idempotent · 멱등
-
명령줄 인터페이스
CLI · command-line interface · command line interface · 커맨드 라인 인터페이스 · 명령행 인터페이스
-
모놀리스
monolith · 모놀리식 아키텍처 · monolithic architecture · 모놀리식 애플리케이션 · monolithic application
-
모니터링
monitoring
-
모델 서빙
model serving · 서빙 · 모델 서버 · ML 서빙
-
모수
parameter · population parameter · 모수치
-
모집단
population · 통계 모집단
-
모킹 프레임워크
mocking framework · mock framework · mocking library · 모킹 라이브러리 · 목 프레임워크
-
무계 데이터
unbounded data · unbounded dataset · 무한 데이터 · 무한 데이터셋 · 비유계 데이터
-
무상태
stateless · 스테이트리스 · 무상태성
-
무작위 표본
random sample · 랜덤 샘플 · 임의 표본 · 무작위 샘플
-
무효화
invalidation · cache invalidation · 캐시 무효화
-
문맥 교환
context switch · context switching · 컨텍스트 스위치 · 컨텍스트 스위칭
-
문맥 자유 문법
context-free grammar · CFG · 문맥 무관 문법
-
문서 길이
Document Length
-
문자 인코딩
character encoding · 문자 부호화 · 캐릭터 인코딩
-
문자소 클러스터
grapheme cluster · extended grapheme cluster · 그래핌 클러스터 · 확장 문자소 클러스터 · user-perceived character
-
물리 기반 셰이딩
PBS · PBR · physically based shading · physically based rendering · 물리 기반 렌더링
-
물리 모델
physical model · physical data model · 물리 데이터 모델 · 물리적 데이터 모델 · 물리적 모델
-
물리 스텝
physics step · 물리 틱 · physics tick · 물리 업데이트 · 시뮬레이션 스텝 · simulation step
-
물리 엔진
physics engine · 물리엔진
-
미니파이
minify · minification · minifier · 미니파이어 · 미니피케이션 · 코드 최소화 · 코드 경량화
-
미스 셰이더
miss shader · 미스 쉐이더 · 빗나감 셰이더
-
민간 시각
civil time · 상용시 · 민간시
-
바꾸기 쉬움
modifiability · 변경 용이성 · 수정 용이성
-
바이트
byte
-
바이트 순서 표시
BOM · Byte Order Mark · 바이트 순서 마크
-
바이트 스트림
byte stream · 바이트스트림
-
바이트코드
bytecode · byte code · 바이트 코드
-
박스 트리
box tree
-
반응형 레이아웃
responsive layout · 리스폰시브 레이아웃
-
방화벽
firewall · 파이어월 · 네트워크 방화벽 · 방화벽 규칙
-
배치
batch
-
배치 처리
batch processing · 일괄 처리 · 배칭
-
배포
deployment · software deployment · deploy · 소프트웨어 배포
-
배포 빈도
Deployment Frequency · deployment frequency
-
배포 재작업률
rework rate · deployment rework rate · 재작업률
-
백분위수
percentile · 백분위 · 퍼센타일
-
백업과 복구
backup and recovery · backup · restore · 백업 · 복구 · backup and restore
-
백오프
backoff · back-off
-
백프레셔
backpressure · back pressure · 배압 · 역압
-
백필
backfill · backfilling · 소급 적재
-
버그 바운티
bug bounty · bug bounty program · 버그 바운티 프로그램 · 버그 현상금 · 취약점 포상제
-
버그 배시
bug bash · bug-bash · 버그 배쉬
-
버스
Bus · 컴퓨터 버스
-
버저닝
Versioning · 버전 매기기 · API 버저닝 · API 버전 관리
-
버전관리
version control · 버전 관리 · revision control · 리비전 관리 · source control · 소스 코드 관리
-
버킷
bucket
-
버퍼
buffer
-
버퍼 뷰
buffer view · bufferView · VkBufferView
-
번들러
bundler · module bundler · 모듈 번들러 · 자바스크립트 번들러
-
법선
normal · surface normal · 노멀
-
벤치마크
benchmark · 벤치마킹 · benchmarking · 벤치 마크
-
벽시계
wall clock · wall-clock time · 벽시계 시각 · 벽시계 시간
-
변경 데이터 캡처
Change Data Capture · CDC · 변경 데이터 수집 · 체인지 데이터 캡처
-
변경 리드 타임
change lead time · lead time for changes · lead_time_for_changes
-
변경 실패율
change fail rate · change failure rate
-
변수
variable · variables
-
변환
transformation · transform · 데이터 변환 · data transformation
-
병렬 실행
parallel execution · 테스트 병렬 실행 · parallel test execution · 병렬 테스트
-
병렬성
parallelism · 병렬
-
병목
bottleneck · 보틀넥 · 병목 지점 · 병목 구간
-
병합
merge · 머지
-
병합 커밋
merge commit · 머지 커밋
-
보존 기간
데이터 보존 기간 · 리텐션 · retention period · retention
-
복잡도 클래스
complexity class · 계산 복잡도 클래스
-
복제
replication · 리플리케이션 · 레플리케이션
-
복제 지연
replication lag · replica lag · 리플리케이션 랙 · 레플리카 지연 · 복제 랙
구현체 124
-
AWS
Amazon Web Services · 아마존 웹 서비스 · aws
-
AWS IAM
IAM · Identity and Access Management
-
AWS IoT Core
IoT Core · aws iot core · 아이오티 코어
-
AWS Lambda
Lambda · AWS 람다 · aws lambda
-
Airbyte
에어바이트 · airbyte
-
Amazon S3
S3 · Simple Storage Service · 아마존 S3
-
Amazon SNS
SNS · AWS SNS · Simple Notification Service
-
Amazon SQS
SQS · Simple Queue Service · 아마존 SQS
-
Android
안드로이드 · android · Android OS
-
Android Developers
developer.android.com · 안드로이드 디벨로퍼스 · 안드로이드 개발자 사이트
-
Apache Airflow
Airflow · 에어플로 · 에어플로우 · 아파치 에어플로
-
Apache Atlas
Atlas · 아틀라스 · 아파치 아틀라스
-
Apache Beam
Beam · 아파치 빔 · 빔
-
Apache Iceberg
Iceberg · 아이스버그 · 아파치 아이스버그
-
Apache Kafka
Kafka · 카프카 · 아파치 카프카
-
Apache Lucene
Lucene · 루씬 · 아파치 루씬
-
Apache Spark
Spark · 스파크 · 아파치 스파크
-
App Store Connect
앱스토어 커넥트 · 앱 스토어 커넥트 · iTunes Connect
-
Azure
Microsoft Azure · 애저
-
C
C 언어 · C언어
-
C++
C with Classes
-
Cassandra
카산드라 · Apache Cassandra · 아파치 카산드라
-
Cloud Logging
클라우드 로깅 · Stackdriver Logging · 스택드라이버 로깅 · Google Cloud Logging
-
CloudFormation
AWS CloudFormation · 클라우드포메이션 · 클라우드 포메이션
-
CloudWatch
Amazon CloudWatch · 클라우드워치 · 아마존 클라우드워치
-
Cloudflare
cloudflare · 클라우드플레어
-
Cortex-M
Arm Cortex-M · 코텍스-M · Cortex-M 프로세서
-
D
D 언어 · D 프로그래밍 언어 · Dlang · dlang
-
Debezium
디비지움 · 데비지움
-
Debian
debian · 데비안 · Debian GNU/Linux · 데비안 리눅스
-
Django
장고
-
Docker
도커 · docker
-
Ehcache
Ehcache 3 · org.ehcache
-
Elasticsearch
엘라스틱서치
-
Firebase Cloud Messaging
FCM · 파이어베이스 클라우드 메시징 · Firebase 클라우드 메시징
-
Firecracker
firecracker · 파이어크래커 · Firecracker microVM · 파이어크래커 마이크로VM
-
Fluent Bit
플루언트비트
-
Flutter
플러터
-
FreeBSD
freebsd · 프리BSD
-
Gatling
개틀링 · gatling
-
Git
깃 · git
-
Git LFS
Git Large File Storage · git-lfs · 깃 LFS
-
GitHub
깃허브 · github · github.com
-
GitHub Actions
깃허브 액션 · 깃허브 액션스 · github actions
-
GitLab
깃랩 · gitlab · gitlab.com
-
Go
Go 언어 · Golang · golang · 고랭
-
Google Cloud Storage
GCS · Google 클라우드 스토리지 · 구글 클라우드 스토리지 · Cloud Storage
-
Gradle
그래들 · Gradle Build Tool
-
Great Expectations
GX · GX Core · 그레이트 익스펙테이션스 · 그레이트 익스펙테이션
-
HDFS
Hadoop Distributed File System · 하둡 분산 파일 시스템
-
HLSL
High Level Shader Language · High-Level Shading Language
-
Hadoop
하둡 · Apache Hadoop
-
ImageNet
이미지넷 · ImageNet dataset · ImageNet-1K
-
JDK
Java Development Kit · 자바 개발 키트
-
JMeter
Apache JMeter
-
JRE
Java Runtime Environment · 자바 실행 환경
-
JUnit
JUnit 5 · 제이유닛
-
Java
자바 · 자바 언어
-
JavaScript
자바스크립트 · JS
-
Jetpack Compose
Compose · 컴포즈 · 젯팩 컴포즈
-
KVM
Kernel-based Virtual Machine · 커널 기반 가상 머신
-
Kotlin
코틀린 · Kotlin 언어 · 코틀린 언어
-
Kubernetes
쿠버네티스 · K8s
-
Linux
linux · 리눅스 · Linux kernel · 리눅스 커널
-
Locust
locust · locustfile · HttpUser
-
MDN
MDN Web Docs · Mozilla Developer Network · developer.mozilla.org
-
MapReduce
맵리듀스 · Hadoop MapReduce
-
Maven
메이븐 · Apache Maven · 아파치 메이븐
-
MediaWiki
미디어위키 · Mediawiki
-
Mercurial
머큐리얼 · hg · mercurial
-
Metal
Metal API · 메탈 · Apple Metal
-
MongoDB
mongodb · 몽고DB · 몽고디비
-
Multics
멀틱스 · MULTICS · Multiplexed Information and Computing Service
-
MySQL
MySQL Server · mysqld
-
NAT 게이트웨이
NAT Gateway · AWS NAT Gateway · NAT GW
-
Node.js
노드JS · nodejs · 노드제이에스
-
Okapi
Okapi IR system · Okapi 검색 시스템 · 오카피
-
OpenCV
Open Source Computer Vision Library · opencv-python · cv2
-
OpenJDK
오픈JDK · OpenJDK 프로젝트
-
OpenSearch
오픈서치
-
Oracle
Oracle Database · 오라클 · 오라클 데이터베이스
-
Packer
packer · 패커 · HashiCorp Packer
-
Perforce
퍼포스 · P4 · p4 · Helix Core · Perforce Helix · Perforce P4
-
Play Console
Google Play Console · 플레이 콘솔 · 구글 플레이 콘솔
-
Playwright
플레이라이트
-
PostgreSQL
postgres · Postgres · 포스트그레스
-
PostgreSQL 전문 검색
PostgreSQL full-text search · PostgreSQL Full Text Search · Postgres 전문 검색 · PostgreSQL 텍스트 검색
-
Prometheus
프로메테우스
-
Python
파이썬
-
RCS
Revision Control System · 리비전 제어 시스템
-
Rails
Ruby on Rails · rails
-
React
react · 리액트
-
React Native
리액트 네이티브 · react-native · RN
-
Redis
redis · 레디스
-
Rust
Rust 언어 · 러스트
-
S3 Glacier
Glacier · Amazon S3 Glacier
-
SCCS
Source Code Control System · 소스 코드 제어 시스템
-
SQLAlchemy
SQL알케미 · 에스큐엘알케미
-
SQLite
sqlite · sqlite3
-
Subversion
SVN · Apache Subversion · 서브버전
-
Swift
스위프트 · Swift 언어 · 스위프트 언어
-
SwiftUI
스위프트UI · 스위프트 UI
- Symfony
-
TalkBack
talkback · 토크백 · Android TalkBack
-
U-Boot
Das U-Boot · 유부트 · uboot · Universal Boot Loader
-
WatchKit
워치킷 · Watch Kit
-
Windows
윈도우 · 윈도우즈 · windows · Microsoft Windows · MS Windows
-
Zephyr
Zephyr OS · Zephyr RTOS · Zephyr Project
-
bcache
block layer cache · 블록 계층 캐시
-
coverage.py
coverage · Coverage.py
-
dbt
data build tool · dbt Core · 디비티
-
dm-cache
dm cache · device-mapper cache · 디바이스 매퍼 캐시
-
etcd
엣시디
-
groupcache
그룹캐시
-
iOS
아이오에스 · ios · iPhone OS
-
k6
Grafana k6
-
kubelet
큐블릿 · node agent
-
memcached
Memcached
-
netfilter
넷필터 · Netfilter
-
nginx
engine x
-
pytest
파이테스트 · py.test
-
scikit-learn
sklearn · 사이킷런 · 사이킷 런
-
그린렛
greenlet
-
다이렉트 렌더링 매니저
Direct Rendering Manager · DRM · 리눅스 DRM · DRM 서브시스템
표준 82
-
ARIA
WAI-ARIA · Accessible Rich Internet Applications
-
Arm
ARM · Arm 아키텍처 · Arm architecture
-
CSSOM
CSS Object Model · CSS 객체 모델
-
CVE
Common Vulnerabilities and Exposures · CVE ID · CVE 번호 · 공통 취약점 및 노출
-
CVSS
Common Vulnerability Scoring System · 공통 취약점 점수 체계
-
CWE
Common Weakness Enumeration · 공통 약점 목록 · 공통 취약점 유형 목록
-
Cache-Control
cache-control · 캐시 컨트롤
-
Content-Type
Content-Type 헤더 · Content-Type 필드 · 콘텐츠 타입
-
Content-Type charset
charset 매개변수 · charset 파라미터 · Content-Type 의 charset
-
DOM
Document Object Model · 문서 객체 모델 · DOM Standard
-
Direct3D
D3D · 다이렉트3D
-
Direct3D 11
D3D11 · 다이렉트3D 11 · DirectX 11
-
ETag
ETag 헤더 · ETag 필드
-
Expires
Expires 헤더 · Expires 필드
-
GLSL
OpenGL Shading Language · 오픈지엘 셰이딩 언어 · 지엘에스엘
-
GraphQL
GraphQL Specification · October2021 Edition
-
HSTS
HTTP Strict Transport Security · Strict-Transport-Security · HTTP 엄격 전송 보안
-
HTML Living Standard
HTML Standard · HTML 표준 · WHATWG HTML
-
IANA 문자 집합 레지스트리
Character Sets · IANA Character Sets · IANA charset registry · 문자 집합 레지스트리
-
ID 토큰
ID token · id_token · 아이디 토큰
-
IEEE 1471
IEEE Std 1471-2000 · IEEE 1471-2000 · ANSI/IEEE 1471 · Recommended Practice for Architectural Description of Software-Intensive Systems · ISO/IEC 42010:2007
-
IP
Internet Protocol · 인터넷 프로토콜 · 인터넷 규약
-
IPv4
Internet Protocol version 4 · IP version 4
-
ISO 8601
ISO 8601 형식 · ISO 날짜 표기
-
IndexedDB
Indexed Database API · IndexedDB API · 인덱스드 DB
-
JVM
Java Virtual Machine · 자바 가상 머신
-
JWT
JSON Web Token
-
Java SE
자바 SE · 자바 표준판 · Java Platform Standard Edition
-
KS X 1001
KS C 5601 · KSC-5601 · ks_c_5601-1987
-
Last-Modified
Last-Modified 헤더 · Last-Modified 필드 · 마지막 수정 시각
-
OAuth 2.0
OAuth2 · OAuth 2
-
OSI 참조 모델
OSI reference model · OSI model · OSI Basic Reference Model · Basic Reference Model · OSI 모델 · OSI 7계층 · OSI 7계층 모델 · OSI 기본 참조 모델 · 개방형 시스템 상호연결 참조 모델
-
OpenAPI
OpenAPI Specification · OAS · OpenAPI 문서 · OpenAPI 규격 · Swagger Specification
-
OpenGL
Open Graphics Library · 오픈GL
-
OpenLineage
Open Lineage · 오픈리니지 · OpenLineage 규격
-
OpenTelemetry
OTel · 오픈텔레메트리
-
PCI DSS
Payment Card Industry Data Security Standard · 결제 카드 산업 데이터 보안 표준 · PCI-DSS
-
RFC
Request for Comments · RFC Series
-
RFC 1035
Domain Names - Implementation and Specification
-
RFC 1557
Korean Character Encoding for Internet Messages · RFC1557
-
RFC 2119
Key words for use in RFCs to Indicate Requirement Levels · RFC2119
-
RFC 2130
The Report of the IAB Character Set Workshop · IAB 문자 집합 워크숍 보고서 · RFC2130
-
RFC 3629
RFC3629 · STD 63
-
RFC 4949
Internet Security Glossary · 인터넷 보안 용어집
-
RFC 5905
NTPv4 · NTP 4판 · NTP 버전 4 · Network Time Protocol Version 4
-
RFC 6749
The OAuth 2.0 Authorization Framework · OAuth 2.0 인가 프레임워크 · RFC6749
-
RFC 9110
HTTP Semantics · STD 97
-
RFC 9111
HTTP Caching · STD 98
-
RFC 9112
STD 99
-
RISC-V
리스크 파이브 · RISC-V ISA
-
RateLimit 헤더 필드
RateLimit · RateLimit-Policy · RateLimit header fields · RateLimit 헤더 · 레이트 리밋 헤더
-
SP 800-63
NIST SP 800-63 · SP 800-63-4 · NIST SP 800-63-4 · Digital Identity Guidelines · 디지털 신원 지침
-
SQL
Structured Query Language · ISO/IEC 9075
-
TAI
International Atomic Time · Temps Atomique International · 국제원자시 · 국제 원자시
-
UTC
Coordinated Universal Time · 협정 세계시 · 세계 협정시 · UTC 시각
-
Unicode
유니코드 · 유니코드 표준 · The Unicode Standard
-
Vary
Vary 헤더 · Vary 필드
-
Vulkan
불칸 · Vulkan API · Vulkan Specification
-
WCAG
Web Content Accessibility Guidelines · 웹 콘텐츠 접근성 지침
-
WGSL
WebGPU Shading Language · WebGPU 셰이딩 언어 · 더블유지에스엘
-
WHATWG Encoding Standard
Encoding Standard · 인코딩 표준 · WHATWG 인코딩 표준
-
WWW-Authenticate
WWW-Authenticate 헤더 · WWW-Authenticate header · 인증 요구 헤더
-
WebAssembly
웹어셈블리 · Wasm
-
WebGL
Web Graphics Library · 웹GL · WebGL API
-
WebGPU
Web GPU · WebGPU API
-
X.509
X.509v3 · X.509 인증서
-
alt 속성
alt attribute
-
aria-hidden
aria-hidden 속성
-
aria-label
aria-label 속성
-
max-age
max age · 맥스 에이지 · Cache-Control max-age
-
meta charset
meta charset 태그 · charset 속성 · meta 요소의 charset
-
no-store
no store · Cache-Control no-store · 노 스토어
-
role
role 속성 · ARIA 역할 · ARIA role
-
sRGB
standard RGB · IEC 61966-2-1
-
stale-if-error
stale if error · 스테일 이프 에러
-
stale-while-revalidate
stale while revalidate · SWR · 스테일 와일 리밸리데이트
-
tabindex
tabindex 속성
-
x86
IA-32 · Intel 64
-
그레고리력
Gregorian calendar · 그레고리오력 · 그레고리우스력
-
대소문자 접기
case folding · Case Folding · 케이스 폴딩
-
라이브 리전
live region · 라이브 영역 · aria-live 영역
-
미디어 타입
media type · MIME 타입 · MIME type
프로토콜 45
-
2단계 커밋
2PC · two-phase commit · Two-Phase Commit Protocol
-
3방향 핸드셰이크
three-way handshake · 3-way handshake · 쓰리웨이 핸드셰이크 · 세 방향 핸드셰이크 · TCP 핸드셰이크 · 3WHS · three message handshake
-
ARP
Address Resolution Protocol · 주소 결정 프로토콜 · 주소 해석 프로토콜
-
BGP
Border Gateway Protocol · 경계 게이트웨이 프로토콜 · 경계 경로 프로토콜 · BGP-4
-
CAN
Controller Area Network · CAN 버스 · CAN bus · 컨트롤러 영역 네트워크
-
CORS
Cross-Origin Resource Sharing · 교차 출처 리소스 공유 · 교차 출처 자원 공유
-
DNS
Domain Name System · 도메인 네임 시스템
-
FTP
File Transfer Protocol · 파일 전송 프로토콜
-
HTTP
Hypertext Transfer Protocol · 하이퍼텍스트 전송 프로토콜
-
HTTP 인증
HTTP authentication · HTTP Authentication · HTTP 인증 프레임워크 · HTTP authentication framework
-
HTTP-1.1
HTTP/1.1 · HTTP 1.1 · HTTP version 1.1
-
HTTP-2
HTTP/2 · h2 · HTTP version 2
-
HTTP-3
HTTP/3 · h3 · HTTP version 3
-
HTTPS
HyperText Transfer Protocol Secure · HTTP over TLS · 보안 HTTP
-
I2C
I²C · IIC · TWI · Inter-Integrated Circuit · 집적 회로 간 통신 · I2C 버스
-
I3C
Improved Inter-Integrated Circuit · MIPI I3C · I3C 버스 · 개량 집적 회로 간 통신
-
ICMP
Internet Control Message Protocol · 인터넷 제어 메시지 프로토콜
-
IPv6
Internet Protocol version 6 · IP version 6 · 인터넷 프로토콜 6판
-
NFS
Network File System
-
NTP
Network Time Protocol · 네트워크 시간 프로토콜
-
OSPF
Open Shortest Path First · 개방형 최단 경로 우선 · OSPFv2 · OSPFv3
-
OpenID Connect
OIDC
-
OpenID Connect 디스커버리
OpenID Connect Discovery · OIDC Discovery · OIDC 디스커버리
-
Paxos
Basic Paxos · Multi-Paxos
-
QUIC
QUIC version 1
-
RIP
Routing Information Protocol · 라우팅 정보 프로토콜 · RIPv2 · RIP-2 · RIPv1 · RIP-1
-
RPC
Remote Procedure Call · 원격 프로시저 호출 · ONC RPC
-
Raft
Raft 합의 알고리즘 · 래프트
-
SAML
Security Assertion Markup Language · 보안 단언 마크업 언어 · SAML 2.0
-
SCTP
Stream Control Transmission Protocol · 스트림 제어 전송 프로토콜
-
SMTP
Simple Mail Transfer Protocol · 단순 메일 전송 프로토콜 · 메일 전송 프로토콜
-
SNMP
Simple Network Management Protocol · 간이 망 관리 프로토콜
-
SOCKS
SOCKS 프록시 · SOCKS5
-
SPI
Serial Peripheral Interface · 직렬 주변 장치 인터페이스 · SPI 버스
-
Server-Sent Events
server-sent events · 서버 전송 이벤트 · 서버 센트 이벤트
-
TLS
Transport Layer Security · 전송 계층 보안
-
Telnet
TELNET · 텔넷
-
UART
Universal Asynchronous Receiver-Transmitter · 범용 비동기 송수신기 · 유아트
-
UDP
User Datagram Protocol · 사용자 데이터그램 프로토콜
-
WebAuthn
Web Authentication · 웹 인증 · Web Authentication API · 웹어센
-
gRPC
gRPC Remote Procedure Calls · 지알피씨
-
가십
Gossip · 가십 프로토콜 · Gossip protocol · 감염형 전파 · 에피데믹 프로토콜
-
경로 MTU 탐색
Path MTU Discovery · PMTUD
-
라우팅 프로토콜
routing protocol · 경로 제어 프로토콜
-
롱 폴링
long polling · long-polling · 롱폴링 · 롱 풀링
패턴 41
-
4+1 뷰
4+1 view model · 4+1 뷰 모델 · 4+1 아키텍처 뷰 모델 · 4+1 architectural view model · 크루첸 4+1 뷰
-
API 게이트웨이
API gateway · API Gateway
-
BFF
Backend for Frontend · Backends for Frontends · Backend for Frontends · 프론트엔드를 위한 백엔드 · BFF 패턴
-
C4 모델
C4 · C4 model · C4 Model · C4 다이어그램 · C4 모델 다이어그램
-
CQRS
Command Query Responsibility Segregation · 명령 조회 책임 분리 · 명령과 조회의 책임 분리 · 명령 질의 책임 분리 · CQRS 패턴
-
Corporate Information Factory
CIF · corporate information factory · 코퍼레이트 인포메이션 팩토리 · Inmon 아키텍처 · 인몬 아키텍처
-
GitOps
깃옵스 · Git Ops · 깃 옵스
-
MVCC
multiversion concurrency control · Multiversion Concurrency Control · Multi-Version Concurrency Control · 다중 버전 동시성 제어 · 다중버전 동시성 제어 · 다중 버전 병행 제어
-
REST
Representational State Transfer · 표현 상태 전이 · RESTful · REST API
-
USE 방법
USE method · USE 메서드 · USE 방법론 · Utilization Saturation and Errors · 사용률 포화 오류 점검
-
WAL
Write-Ahead Logging · write-ahead log · 미리 쓰기 로그 · WAL 모드
-
cache-as-sor
cache-as-SoR · cache as SoR · cache-as-system-of-record · 캐시 애즈 SoR
-
cache-aside
캐시 어사이드 · cache aside · lazy loading
-
n-tier
n-tier architecture · N티어 아키텍처 · N티어 · multitier architecture · multi-tier architecture · 멀티티어 아키텍처 · 다중 티어 아키텍처
-
read-through
read through · 리드 스루 · read-through caching · Read-Through
-
refresh-ahead
refresh ahead · Refresh-Ahead · refresh-ahead caching · 리프레시 어헤드
-
request collapsing
request coalescing · collapsed forwarding · duplicate suppression · 요청 병합
-
write-around
write around · writearound · no-write allocate · write-no-allocate
-
write-behind
write-back · writeback · write behind · 지연 쓰기
-
write-through
write through · writethrough · 라이트 스루
-
게임 루프
game loop · 게임루프 · 메인 루프 · main loop
-
견고성 원칙
robustness principle · Postel's law · 포스텔의 법칙 · 포스텔 법칙 · 견고성의 원칙
-
경계 컨텍스트
바운디드 컨텍스트 · Bounded Context · 제한된 컨텍스트 · 경계된 컨텍스트
-
고정 타임스텝
fixed timestep · fixed time step · fixed time-step · 고정 시간 간격
-
골든 시그널
golden signals · four golden signals · 네 가지 황금 신호 · the four golden signals
-
관심사 분리
separation of concerns · 관심의 분리 · 관심사의 분리
-
기능 플래그
feature flag · feature toggle · 기능 토글 · 피처 플래그 · 기능 스위치
-
낙관적 잠금
optimistic locking · Optimistic Locking · optimistic concurrency control · 낙관적 락 · 낙관적 동시성 제어 · 낙관적잠금
-
느슨한 정족수
sloppy quorum · 슬로피 쿼럼
-
단계적 출시
staged rollout · phased release · phased rollout · incremental rollout · 단계별 배포
-
데이터 레이크
data lake · 데이터레이크
-
도메인 주도 설계
DDD · Domain-Driven Design · 도메인 드리븐 디자인 · 도메인 주도 설계 방법론
-
레이어드
layered architecture · 레이어드 아키텍처 · 계층형 아키텍처 · 계층 아키텍처 · layered pattern
-
롤링 업데이트
rolling update · rolling deployment · rolling upgrade · 롤링 배포 · 롤링 업그레이드
-
리버스 프록시
reverse proxy · surrogate · 리버스프록시
-
리스
lease · leases · leasehold · 리스 기간
-
마이크로서비스
microservices · 마이크로서비스 아키텍처 · microservice architecture
-
메모이제이션
memoization · memoize · memo function
-
모듈러 모놀리스
modular monolith · 모듈식 모놀리스 · 모듈형 모놀리스 · modulith
-
목 객체
mock object · Mock Object · mock · 목 · 모의 객체 · 목 오브젝트
-
반-엔트로피
anti-entropy · 안티 엔트로피
알고리즘 39
-
Argon2id
argon2id · Argon2 id
-
BM25
Okapi BM25 · Best Matching 25
-
LFU
Least Frequently Used · 최소 빈도 사용 · LFU 캐시 · LFU 축출
-
LRU
Least Recently Used · 최근 최소 사용
-
MD5
Message-Digest Algorithm 5 · 메시지 다이제스트 알고리즘 5
-
PBKDF2
Password-Based Key Derivation Function 2 · 비밀번호 기반 키 유도 함수 2
-
SHA-1
SHA1 · Secure Hash Algorithm 1
-
SHA-256
SHA256 · Secure Hash Algorithm 256
-
TF-IDF
Term Frequency-Inverse Document Frequency · 낱말 빈도-역문서 빈도 · 단어 빈도-역문서 빈도 · tf-idf · TF*IDF
-
bcrypt
비크립트
-
개방 주소법
open addressing · 열린 주소법 · 오픈 어드레싱
-
결정 트리
decision tree · 의사결정나무 · 의사 결정 트리 · 결정 나무 · 결정 트리 모델
-
경사 하강법
gradient descent · 경사하강법 · 그래디언트 디센트 · 기울기 하강법
-
광선 교차 판정
ray intersection test · ray intersection · ray-primitive intersection · ray-triangle intersection · 광선 교차 검사 · 레이 교차 판정
-
광선 순회
ray traversal · BVH traversal · BVH 순회 · 레이 순회
-
광선 추적
ray tracing · raytracing · 레이 트레이싱 · 레이트레이싱 · 광선 추적법
-
교차 검증
cross-validation · 교차검증
-
그리디 알고리즘
greedy algorithm · 탐욕 알고리즘 · 탐욕법 · 그리디 · 욕심쟁이 알고리즘
-
근사 최근접 이웃
근사 최근접 이웃 검색 · 근사 최근접 이웃 탐색 · Approximate Nearest Neighbor · Approximate Nearest Neighbor Search · ANN 검색
-
깊이 우선 탐색
DFS · depth-first search · 깊이 우선 순회 · 깊이우선탐색
-
난수 생성기
random number generator · RNG · 난수 발생기 · 난수 생성
-
너비 우선 탐색
BFS · breadth-first search · 넓이 우선 탐색
-
다익스트라 알고리즘
Dijkstra's algorithm · Dijkstra algorithm · 데이크스트라 알고리즘 · 다익스트라
-
동적 계획법
dynamic programming · DP · 다이나믹 프로그래밍 · 동적 프로그래밍
-
라디오시티
radiosity · 래디오시티 · 라디오시티 방법 · radiosity method
-
래스터화
Rasterization · 래스터라이제이션
-
랜덤 포레스트
random forest · random forests · 랜덤 포리스트 · 무작위 숲 · 랜덤 포레스트 모델
-
램포트 시계
Lamport clock · Lamport timestamp · 램포트 타임스탬프 · 램포트 클록
-
리더 선출
leader election · 리더 뽑기 · 대표 선출
-
멀티샘플링
multisampling · MSAA · multisample anti-aliasing · 멀티샘플 안티에일리어싱
-
무게중심 보간
barycentric interpolation · Barycentric interpolation · 무게중심 좌표 보간 · 바리센트릭 보간 · 중심 좌표 보간
-
문서 군집화
document clustering · Document Clustering · 문서 클러스터링 · 텍스트 군집화 · 텍스트 클러스터링 · 문서 군집
-
배낭 문제
knapsack problem · 0-1 배낭 문제 · 0/1 knapsack problem · 냅색 문제 · 냅색 · 배낭문제
-
벡터 검색
Vector Search · 벡터 유사도 검색 · Vector Similarity Search
-
벡터 공간 모델
Vector Space Model · VSM · 벡터 모델 · 벡터 공간 검색 모델
-
벡터 시계
vector clock · 벡터클록 · 벡터 클럭
-
병합 정렬
merge sort · 합병 정렬 · 머지 소트 · mergesort
-
보간
interpolation · Interpolation · 인터폴레이션 · 사이값 계산 · 보간법
-
부분 문자열 매칭
문자열 매칭 · 부분 문자열 검색 · 문자열 검색 · string matching · substring search · string searching
문제 31
-
ABA 문제
ABA problem · ABA · ABA 현상
-
ANR
Application Not Responding · 앱 응답 없음 · 안드로이드 응답 없음
-
GC 스파이크
GC spike · garbage collection spike · 가비지 컬렉션 스파이크 · GC 히치 · GC hitch
-
SQL 인젝션
SQL injection · SQLi
-
Z-파이팅
Z-fighting · Z fighting · z-fighting · Z 파이팅 · Z파이팅 · 깊이 파이팅 · depth fighting
-
간헐적 실패
intermittent failure · intermittent test failure · 간헐적 장애 · 간헐 실패
-
거짓 공유
false sharing · 폴스 셰어링 · 거짓공유
-
경쟁 상태
race condition · 레이스 컨디션 · 경합 조건
-
과적합
overfitting · 오버피팅 · 과대적합
-
교차 사이트 스크립팅
Cross-Site Scripting · XSS · 크로스 사이트 스크립팅 · type-0 XSS
-
구성 드리프트
configuration drift · 설정 드리프트 · 구성 표류 · 인프라 드리프트
-
기아
기아 상태 · starvation · 굶주림
-
깊이 비교 오류
depth comparison error · depth test error · 깊이 테스트 오류 · 깊이 판정 오류 · 뎁스 비교 오류
-
낡은 데이터
stale data · stale response · 스테일 데이터 · 오래된 데이터
-
다중 비교
multiple comparisons · multiple testing · 다중 비교 문제 · 다중 검정
-
데드락
deadlock · 교착 상태 · 교착상태 · system deadlock
-
데이터 누수
data leakage · 데이터 리키지 · 정보 누수
-
데이터 레이스
data race · 데이터 경합
-
라우팅 루프
routing loop
-
라이브락
livelock · 라이브 락
-
락 경합
lock contention · 잠금 경합 · 락 컨텐션
-
레이아웃 이동
layout shift · Layout Instability · 레이아웃 시프트
-
렌더 패스 데이터 레이스
render pass data race · 렌더 패스 동기화 해저드
-
롤백 불가 마이그레이션
irreversible migration · 되돌릴 수 없는 마이그레이션 · 비가역 마이그레이션
-
메모리 누수
memory leak · 메모리 릭 · 메모리 누출
-
메인 스레드 차단
main thread blocking · 메인 스레드 블로킹 · UI 스레드 차단 · UI 스레드 블로킹
-
모지바케
mojibake · 文字化け · 글자 깨짐 · 한글 깨짐
-
배포 중 스키마 불일치
schema mismatch during deployment · 배포 중 스키마 어긋남 · 스키마-코드 불일치
-
버퍼 오버플로
buffer overflow · 버퍼 오버플로우 · 버퍼 넘침
-
병합 충돌
merge conflict · 머지 충돌 · 머지 컨플릭트
-
보안 설정 오류
security misconfiguration · 보안 구성 오류 · 잘못된 보안 설정
포맷 27
-
ASCII
ascii · 아스키 · American Standard Code for Information Interchange · 미국 정보 교환 표준 부호 · US-ASCII
-
Apache Parquet
Parquet · 파케이 · 아파치 파케이
-
CP949
cp949 · CP-949 · MS949 · ms949 · windows-949 · 코드 페이지 949 · UHC · Unified Hangul Code · 통합형 한글 코드 · 확장 완성형
-
CSS
Cascading Style Sheets · 캐스케이딩 스타일 시트
-
EUC-KR
euc-kr · euckr · EUC_KR · Extended Unix Code for Korean · 한국어 EUC
-
GPU 텍스처 포맷
texture format · GPU texture format · 텍스처 포맷
-
HCL
HashiCorp Configuration Language · 해시코프 설정 언어
-
HTML
HyperText Markup Language · 하이퍼텍스트 마크업 언어
-
ISO-2022-KR
iso-2022-kr · ISO2022KR · iso2022_kr · csISO2022KR
-
JAR
jar · Java Archive · 자바 아카이브 · JAR 파일
-
JSON
JavaScript Object Notation · 제이슨
-
MIME
Multipurpose Internet Mail Extensions · 다목적 인터넷 메일 확장
-
RFC 3339
인터넷 날짜·시각 형식 · Internet Date/Time Format
-
SOA 레코드
SOA record · Start of Authority record · 권한 시작 레코드
-
SPIR-V
SPIRV · spir-v · Standard Portable Intermediate Representation · SPIR-V 모듈
-
URI
Uniform Resource Identifier · 통합 자원 식별자
-
URL
Uniform Resource Locator · 자원 위치 지정자
-
UTF-16
utf-16 · utf16 · Unicode Transformation Format 16-bit · 유니코드 변환 형식 16비트
-
UTF-32
utf-32 · utf32 · Unicode Transformation Format 32-bit · 유니코드 변환 형식 32비트
-
UTF-8
utf-8 · utf8 · Unicode Transformation Format 8-bit · 유니코드 변환 형식 8비트
-
UUID
Universally Unique Identifier · 범용 고유 식별자 · GUID
-
XML
Extensible Markup Language · 확장 가능 마크업 언어
-
glTF
GL Transmission Format · gltf
-
proto 파일
.proto 파일 · proto file · .proto file · 프로토 파일
-
도메인 이름
domain name · 도메인명 · 도메인 네임
-
디바이스 트리
Device Tree · devicetree · 장치 트리 · DTS · DTB
-
리소스 레코드
resource record · 자원 레코드
인터페이스 25
-
Canvas API
캔버스 API · Canvas 2D API · 2D 캔버스 · CanvasRenderingContext2D
-
DELETE
DELETE 메서드 · HTTP DELETE
-
GET
GET 메서드 · 겟
-
HEAD
HEAD 메서드 · HTTP HEAD
-
Intersection Observer
IntersectionObserver · Intersection Observer API · 인터섹션 옵저버 · 교차 관찰자
-
OPTIONS
OPTIONS 메서드 · HTTP OPTIONS
-
POST
POST 메서드 · 포스트
-
PUT
PUT 메서드 · PUT 요청
-
compare-and-set
compare-and-swap · 비교 후 설정 · 비교 후 교체
-
contentDescription
content description · android:contentDescription · setContentDescription · 콘텐츠 설명
-
dmesg
dmesg 명령 · 디메시지
-
ifconfig
interface configuration · ifconfig 명령
-
iostat
input/output statistics · iostat 명령 · 아이오스탯
-
javac
javac 명령 · 자바 컴파일러
-
javap
javap 명령
-
kotlinc
kotlinc 명령
-
netstat
network statistics · netstat 명령 · 넷스탯
-
sar
system activity report · sar 명령 · 사르
-
traceroute
traceroute 명령 · tracert · 경로 추적
-
vmstat
virtual memory statistics · vmstat 명령
-
디플로이먼트
Kubernetes Deployment · 쿠버네티스 디플로이먼트 · apps/v1 Deployment
-
레플리카셋
ReplicaSet · 쿠버네티스 레플리카셋 · apps/v1 ReplicaSet · rs
-
로컬 스토리지
localStorage · Local Storage · window.localStorage · 로컬스토리지
-
리슨
listen · 소켓 리슨 · 리스닝
-
바인드
bind · 소켓 바인드 · 주소 바인드
자료구조 18
-
AVL 트리
AVL tree
-
B-tree
btree · B트리
-
DAG
Directed Acyclic Graph · directed acyclic graph · 유향 비순환 그래프 · 방향 비순환 그래프 · 방향 있는 비순환 그래프 · 비순환 방향 그래프 · acyclic directed graph · oriented acyclic graph
-
LSM 트리
LSM-tree · LSM tree · Log-Structured Merge-tree · 로그 구조 병합 트리
-
SSTable
SST · SST 파일
-
가속 구조
acceleration structure · acceleration structures · 광선 가속 구조 · 레이 트레이싱 가속 구조
-
경로표
routing table · 라우팅 테이블 · 라우팅 표
-
그래프
graph · 그래프 자료구조
-
데이터베이스 인덱스
database index · DB 인덱스
-
딕셔너리
dictionary · 딕셔너리 자료구조
-
레인보우 테이블
rainbow table · 레인보우테이블
-
레코드
record · 레코드형
-
맵
map · 맵 자료구조
-
머클 트리
Merkle tree · hash tree · 해시 트리
-
문자열
string · 스트링
-
밉맵
mipmap · Mipmap · MIP map · 밉맵 사슬 · mipmap chain · 밉맵 피라미드 · mipmapping · 밉매핑
-
배열
array
-
벡터 테이블
vector table · interrupt vector table · 인터럽트 벡터 테이블 · 예외 벡터 테이블
용어함정 16
-
HTML 템플릿
HTML template · HTML templates · template 요소 · 템플릿 요소
-
TTL
Time to Live · Time-to-Live
-
postmaster
Postmaster · 포스트마스터
-
검증자
validator · verifier
-
경로 탐색
pathfinding · path finding · 길찾기 · path traversal
-
관계
relationship · relation
-
노드
node
-
단언
assertion · assert · 어서션
-
대역폭
bandwidth
-
데이터베이스 클러스터
database cluster · 카탈로그 클러스터 · catalog cluster
-
런타임
runtime · run time · running time · 실행 시간 · 실행 환경
-
로컬 저장소
local repository · 로컬 리포지토리 · 로컬 레포
-
리다이렉션
redirection · 리디렉션 · 입출력 리다이렉션 · 입출력 재지정 · HTTP 리다이렉션 · URL 리다이렉션
-
모델
model
-
무결성
integrity · data integrity · 데이터 무결성
-
베어메탈
bare metal · bare-metal · 베어 메탈 · 베어메탈 서버
영역 14
-
API 설계
API design · api design · 인터페이스 설계
-
QA와 테스트
QA · quality assurance · 품질 보증 · testing · 소프트웨어 테스팅 · 테스팅
-
개발
소프트웨어 개발 · software development
-
검색
정보 검색 · information retrieval · search
-
게임 개발
game development
-
그래픽스
computer graphics · 컴퓨터 그래픽스 · graphics
-
네트워크
network · 통신망
-
데브옵스
DevOps · devops · 데브옵스 문화
-
데이터 분석
data analysis · 자료 분석 · 데이터분석
-
데이터 엔지니어링
data engineering · 데이터 엔지니어
-
릴리스 엔지니어링
release engineering · Release Engineering · 릴리스 엔지니어
-
모바일 개발
mobile development · mobile app development · 모바일 앱 개발 · 앱 개발
-
백엔드
backend · back end · 서버 사이드 · server-side · 서버 쪽
-
보안 엔지니어링
security engineering · 보안 공학 · 시스템 보안 공학 · systems security engineering
에러코드 8
-
200 OK
200 · HTTP 200 · 200 (OK) · 상태 코드 200
-
201 Created
201 · HTTP 201 · 201 (Created) · 상태 코드 201
-
EAGAIN
Resource temporarily unavailable
-
EOVERFLOW
Value too large to be stored in data type
-
HTTP 401
401 · Unauthorized · 401 Unauthorized · 상태 코드 401
-
HTTP 403
403 · Forbidden · 403 Forbidden
-
HTTP 429
429 · Too Many Requests · 429 Too Many Requests
-
SIGSEGV
segmentation violation · 시그널 11 · signal 11
한계 3
-
2038 문제
Y2038 · year 2038 problem · 2038
-
FLP 불가능성
FLP · FLP impossibility · FLP impossibility result · FLP 정리 · FLP 결과
-
백그라운드 실행 제한
background execution limits · background execution limit · 백그라운드 제한
사고사례 1
-
GitLab 데이터 삭제 사고
GitLab.com database incident · GitLab 데이터베이스 장애 · GitLab rm -rf 사고
안티패턴 1
-
EAV
entity-attribute-value · 엔티티-속성-값 · EAV/CR · open schema
트레이드오프축 1
-
CAP
CAP 정리 · CAP theorem · Brewer 정리